Jump to content

Haagen IT Partner

Members
  • Posts

    30
  • Joined

  • Last visited

Contact Methods

  • Website URL
    https://haagen.se

Profile Information

  • Gender
    Male
  • Location
    Sweden
  • Interests
    IT, Stocks,MTB and Passwordstate :-)

Recent Profile Visitors

1,339 profile views

Haagen IT Partner's Achievements

  1. Hi Support, Tested and validated after upgrading version 9300 i can confirm the error is now resolved. I can now create a Shared password list and no error occurs while E2 policy is active and permissions are applied correct. However: when E2 policy is in use the GUI act as settings are copied and applied to the new Shared Password List. 1. The Password List Settings are grayed as if it's inherited when they are not since only permissions are in use. 2. This is probably triggered by "Link this Password List to the selected Template" is still checked as default and therefor also graylists the checkboxes since it thinks it's inheritit setting from a template while it's not. When E2 Policy is disabled: 3. After disabling E2 policy and relogging the same Template permissions are choosen as default and the Password List Settings are not grayed, when createing a SPL: the permissions of the Template are applied . When setting the value "- Copy Permissions from Template" (no inherance) the permissions applied is the logged on user. I think when applying permissions via the E2 policy "Link this Password List to the selected Template" get's triggered even if there is only a permission applied and not Template Settings (should be threated differently: settings vs permissions). And when disabling the E2 the settings of "Copy Permissions from Template " are not defaulted correctly since it still inherits values as preselected. Same experience in several different Passwordstate environments, not a huge problem at all but i don't think it works as intended Thanks
  2. Hi Support, I agree on that point and think that if E2 policy or some of these system settings > password list options i sent to you over mail is activated while upgrading from 8995 to 9x version this bug occurs. Shout if you need an example of settings since i have a saved backup of them that always (7/7 migrations) ended up with this error after the upgrade process. Thanks
  3. Hi, Sorry for the delay. Im using a primary website that is listed as Authorised in the Authorized Web Servers section. This instance uses a simple MSSQL Server 2016 Core without replication. I can confirm after upgrading from 8995 to 9xxx and when using the E2 policy that applies permissions to the created Shared Password List is enabled and applied this error occors only. (On two instances) If we take a look at the result of the applied policy when creating a Shared Password List permissions are copied from the Password List Template: PermissionX as set. But there is a small detail here: Take a look at this checkbox that is applied as a default when E2 is enabled. During the process of applying permissions to a not selected Password List or Template and that's why i recieve an SQL error when the DB try to link the attribute to a NULL variable (none existing) Wordkaround 1: If i chose a Shared Password List or Template when this checkbox is applied i recieve no error and the Shared Password List is created since the DB have an attribute to apply to. Wordkaround 2: If i uncheck the box below to not execute a linking the Shared Password List is created without an error as well. How can i disable this prefered Linking for Shared Password Lists while using E2? I have recreated Password List Templates and policies, changed all attributes in Settings and relogged everytime without success. I also have this setting in: Settings\Password List Settings: which not seames to work since it's prechecked when E2 is used. Can you assist me on this part? Since i experience it's a prechecked setting and have to be deselected each time a password list is created if E2 is enabled. I have two separate instances that experiance this after upgradeing from 8550 to 9xxx. Thanks in advance
  4. Hi Support, Okey, yeah i guess something was not applied or converted during the upgrade., the webserver is listed as authorized to read/write in the database. I have sent you a copy of the database schema. Thanks
  5. Hi, After updating Passwordstate we are having problem creating Password Lists and a error sign is shown: When querying the Passwordstate DB it shows the following: Error Code = The statement has been terminated. The INSERT statement conflicted with the FOREIGN KEY constraint "FK_LinkedPasswordLists_PasswordListTemplates". The conflict occurred in database "passwordstate", table "dbo.PasswordListTemplates", column 'PasswordListTemplateID'., StackTrace = at System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method) at System.Data.OleDb.OleDbCommand.ExecuteNonQuery() at (Object ) at Passwordstate.Passwordstate.PasswordList.LinkPasswordListToTemplate(String PasswordListTemplateID, String PasswordListID, String PasswordList, Boolean AddLinkedRecord, Boolean IsPrivate) The Password List is displayed after hitting F5 in browser and is created in the root of the tree instead of the folder in the tree I created in. When creating in root path the issue is the same. This error occurs when i have a User Policy set in E2: The users in E2 all exists and are active and have not been a problem before the upgrade. If I disable the policy or default E2 value and relogg the policy is applied the users can create their Password Lists. . I saw in the release of 9100 there was a fix in this area: Fixed an issue with setting permissions when creating Password Lists under folders with Advanced Permissions model, where settings and permissions were based off a Template via a User Account Policy I don't know if i have missed something in the upgrade proccess or if the upgrade didn't apply the fix during the process? I had to manually install DOT NET 4.7.1 on the core servers via cli before upgrade if that have something to with it. Thanks
  6. Hi Tom, I saw this as well and you can read more here. We can see the clearification on this page that you do need "Annual support and upgrade protection" license for these features to be accessible in version 9+ Minimum license you can buy is 5 so for 1-5 users = 55$ per year. If i do not misinterpret the information Let's see the clarification from @support Regards Tony Haagen IT Partner AB
  7. Hello Click Studios, Is there a "bug" when you use the custom field date picker and try to change the date to older then 1980? :) Verified on two PWS setups with latest PWS version, one with Windows 2012 servers and another with 2016 Core Servers. Thanks, Tony in Sweden Haagen IT Partner AB
×
×
  • Create New...