Jump to content

Issues Configuring Backups


Recommended Posts

Hi, have been using PasswordState in our corporate environment for many years and am quite familiar with how the product works. Some time back I setup the free version for personal use and training purposes.


As I plan to make my personal version available publicly behind a WAF, I did not join this machine to the domain as I saw no strong reason to, and with the design I had in mind would make it more secure this way. Up until now, I have performed VM level backups and performed upgrades manually using the zip file approach which has worked ok. However, to perform GUI based backups, it seems I must enable backups and this is not working so well.


When I follow the instructions:

2.1 Add Passwordstate Server into Passwordstate - this was already complete

2.2 Create Password List with the Enabled for Resets Option Selected - this part is and complete

2.3 Create Password Record - this is where things don't work. I cannot select the hostname via search button. I can type in the hostname, but I cannot save it. Saving the record without the hostname also doesn't work as hostname seems to be a required filed, even though it is not marked with the red *


In my case the URL I use to access PasswordState is different to the hostname considering I have a load balancer / WAF in front - though WAF functionality is disabled while I troubleshoot. 


Hoping somebody may know how to resolve?

Link to comment
Share on other sites


  1. I have now also disabled Azure AD SAML based auth and have switched back to local basic auth for the time being
  2. I have taken the load balancer / WAF out of the way - issue still remains
Edited by mackov83
Extra information
Link to comment
Share on other sites

Further to this, having upgraded our production environment to 9611 today, the process seemed to work perfectly fine for a domain joined PasswordState instance. Therefore interested to know if anybody has successfully created the backup account for a standalone machine.

Link to comment
Share on other sites

  • 4 weeks later...

I just wanted to update and advise that I figured out the issue. 


I misinterpreted section 2.1 for the Hosts addition to be the Administration > Authorized Web Servers. Once I added the VM name under the required Hosts menu item it worked as per the documentation.


Hopefully this helps somebody else if they have the same issue

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...