Jump to content

NGINX Modsecurity Support


mackov83
 Share

Recommended Posts

Having used your product for many years in my existing company I have to say it is one of the easiest tools to use.

 

I am trying to configure PasswordState to run behind an opensource Web Application Firewall (WAF) - Modsecurity running on NGINX. While the NGINX reverse proxy seems to work perfectly fine (found a good link in this forum), as soon as I enable Modsecurity things stop working. Modsecurity is wroking as expected for another site - therefore not a Modsecurity configuration issue as such.

 

While I know this appears to be a Modsecurity issue, have you had any others having similar issues behind other WAFs? 

 

I appreciate any assistance you might be able to provide.

Link to comment
Share on other sites

Hello mackov83,

 

We do not have any experience with that configuration sorry, so cannot really provide any advice on it.

Hopefully someone else in the forums will see you post and provide some guidance on this, if they use that sort of setup. Or possibly log a call on the WAF's support forums to see if other customers have run into issues with other types of web sites? Ours is a ASP.NET application, running in IIS.

Regards

Click Studios

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...