Jump to content

After manual upgrade to 8995, no prompt to upgrade database


JJMicro
 Share

Recommended Posts

My current build number is 8951.

 

I am attempting to update first to version 8995 and then to version 9003 as per the instructions here:

 

https://www.clickstudios.com.au/downloads/version9/Upgrade_Instructions.pdf

I've downloaded 8995, put Passwordstate into Maintenance mode, and run the installer. It installs without issue.

 

However, when the installation finishes and I go to login, it does not prompt me to upgrade the database. And the version still shows as 8951.

 

How do I get it to initiate the database upgrade?

 

At this point, I've tried running the installer again, and it just asks if I want to uninstall or repair my installation. I have tried to repair the installation but I am still not prompted to upgrade the database upon login.

 

Please advise.

Link to comment
Share on other sites

Hello JJMicro,

 

Can you tell us if you have done any hardening on your web server?

With our installer/upgrader, we do use some custom PowerShell scripts to perform various tasks, and we've been made recently aware by a couple of customers that these PowerShell scripts are not executing, due to server hardening.

We're going to try and replicate this ourselves today, and work on a fix if we can. We will post back here once we have more information.

Regards

Click Studios

Link to comment
Share on other sites

Just for fun, I just snoozed my antivirus protection and tried reinstalling the update.

 

It only gives me the option to uninstall or repair at this point. So I chose repair.

 

After the installation finished, I logged back in to Passwordstate and it did not prompt me to upgrade the database.

 

And it's still showing build 8951 at the top.

Link to comment
Share on other sites

Hi JJ,

 

Thanks, and there something strange going on where our PowerShell scripts are just not being executed for some reason, and we cannot seem to replicate this in any of our environments.
 

Could you also do something else for us, so we can try and troubleshoot this issue:

 

  1. Let us know what version of the operating system you are using, and whether it is 32bit or 64bit
  2. Let us know what version of PowerShell and .NET Framework you have installed
  3. And from the run command in Windows, can you try pasting the two separate commands below, and let us know if any of these versions of PowerShell are blocked or not:

 

           C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe

           C:\Windows\SysWOW64\WindowsPowerShell\v1.0\powershell.exe

 

Thanks very much

Click Studios

Link to comment
Share on other sites

64 Bit Server 2012 R2 Standard

 

PowerShell is version 5.1.14409.1018

 

 

See screenshot for all the .NET Framework versions installed: (2.0, 3.0, 3.5, 4.0, and 4.8)

 

Both PowerShell executables open from the Run Command without issue. Both launch PowerShell windows.

image.png

Link to comment
Share on other sites

Okay thanks. It definitely seems like there is something on your system which is blocking execution of our PowerShell scripts with our installers, and we're not sure what it could be now.

We are making some changes to the installer today, to force the use of the 64bit version of PowerShell, so we might need to try that when it's ready, to see if this works for you.

Regards

Click Studios

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...