Jump to content

Database Backups issue in new version using local account and separate servers


SZU
 Share

Recommended Posts

Hello,

 

We are testing new 9 version and getting error when running Test Permissions (on Administration> Backups and Upgrades >Backup Settings):

Quote

It appears you have selected a local Windows account for your backups, but your SQL Server is hosted remotely. This is not a supported configuration, and please use an Active Directory account instead.

Backup setup was configured using manual: https://www.clickstudios.com.au/downloads/version9/Passwordstate_Automatic_Backups_Local_Account.pdf

 

In version 8 same setup (two non domain servers and local users) built-in Passwordstate database backups works fine.

 

This version change has new limit and not support built-in Passwordstate database backups on different non domain server and local account? Or needs to do extra steps?

 

 

 

Link to comment
Share on other sites

Hi SZU, I'm going to paste the email we sent to you below for this, which may help other users when configuring backups:

 

Hi SZU,

 

Unfortunately with the new backups, we are now using Powershell to help improve security and add extra functionality, but the requirements from Microsoft for this are quite complex and difficult to cater for every different type of set up.  For this reason when using a local account we can’t connect to another machine using a second local account. 

 

There’s a couple of things you could try to fix this:

 

  1. Move SQL Express to your web server, as this will work
  2. Disable the database backup portion schedule a database backup outside of Passwordstate.  We can provide the Powershell code if needed to help with this, possibly you could put this into t Windows Scheduled task or alternatively if you have other backup means maybe use those instead?

 

The idea with our local account documentation is to back up everything to the local webserver, and then you would use some other process to copy the backups to a separate location.  I hope this helps, and please let me know if you have any questions about this?

 

Regards,

Support

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...