Jump to content

Accessing API from the server hosting Passwordstate


jomalin
 Share

Recommended Posts

I am trying to access the WinAPI on the server hosting passwordstate and keep getting a permissions issue

 

image.png.52ef220f42401d4abdfc8639428c8b10.png

 

If I run the same commands from a different server it works correctly

 

image.png.af47c95298742c7343d74cfc31090dbe.png

 

It works fine with the API key when run from the passwordstate server

 

image.png.7d13f387f3c5ae64cc6977007a84b7d0.png

Link to comment
Share on other sites

Hello,

That is a bit strange that the behaviour is different from different Hosts.

 

Could you log a support ticket here https://www.clickstudios.com.au/support.aspx, and provide information from this forum post - https://forums.clickstudios.com.au/topic/2518-passwordstate-support-information-script/

We'll have a look at the health of your server for you, and see if we can spot anything obvious.

Regards

Click Studios

 

Link to comment
Share on other sites

We found the issue here is that when browsing to the /winapi URL in your browser, the browser was prompting for domain authentication.

The following forum post shows possible fixes for this issue, and generally Suggestion 1 fixes this issue for most customers - https://forums.clickstudios.com.au/topic/152-why-am-i-being-prompted-to-enter-my-authentication-details/

 

Regards

Click Studios

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...