Jump to content

SSL redirect


Matt

Recommended Posts

Hi

 

We've just purchased PS and I'm trying to figure out the best way to configure the load balancing.

 

We were planning to use SSL Offloading, so the certificate is installed on the LB only and it redirects traffic to one of two web servers to http.  From reading on another topic here, PS does an automatic redirect from HTTP to HTTPS. 

 

Is there a way to stop it doing this and remove the self signed certificate binding from the webservers?

 

I've just realised I have this problem as I have a load balanced CNAME which doesn't work at the moment so I can't complete the initial setup.

 

Thanks

Link to comment
Share on other sites

Hi Matt,

 

You can turn off the SSL redirection on the System Settings screen in Passwordstate - maybe if you RDP'd into the server. Or, using SQL Server Management Studio, you can execute the following command to do this also:

USE Passwordstate

UPDATE SystemSettings SET ForceSSL = 0

 

Regards

Click Studios

Link to comment
Share on other sites

  • 3 months later...

I ran into this problem tonight, however I had to runn the following query

SELECT        ForceSSL
FROM            SystemSettings

 

then change the value from True to False , not sure if you guys are using the numbers anymore or if that is something SQL studio does but running your command did not work.

Link to comment
Share on other sites

Hello,

 

Following your screenshot I was able to determine it had not created the binding for https on 443, I created the binding and selected the correct SSL cert. Changed the database back to force SSL, and it all seems to be loading fine.

 

One question, should it have created this binding during installation? As I did not see any step indicating I needed to do this.

 

Also I have port 9119 in there and it was an option  during install to chose this port. qwj0bxO.png

 

However that port doesn't seem to load anything ? What is it used for, is it necessary to leave this port open ?

Link to comment
Share on other sites

Hello,

 

During the install, the default port specified is 9119 - and this should have created a binding with your certificate on this port. I believe the reason port 443 was not created, was because you did not change the default binding of 9119 to 443. You can now delete 9119 since you have 443 working.

Regards

Click Studios

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...