Jump to content

How to make Passwordstate work on a new URL on the same server


Recommended Posts

We installed the trial with a self signed certificate, liked it and started using it  for real so we want to change to using our domain wildcard certificate so need to add the domain name to the URL name we used.

Following various guide and posts on here we made changes (as below) but the new URL does not link to passwordstate but gives HTTP Error 404.

  • In IIS added binding to the password state web site = https://paswordstate.ourdomain.net rather than https://passwordstate:9119 and in Password state and applied our wildcard certificate
  • In Passwordstate under Authorized Web Servers added new domain name,  passwordstate.ourdomain.net alongside old name passwordstate
  • In Passwordstate - system setting - miscellaneous specified the new domain name https://passwordstate.ourdomain.net
  • Restarted the IIS site and the service and even the whole server.

The new URL works in IIS in that it loads in a browser and the certificate is valid but get HTTP Error 1404. The requested source is not  found.

It is not an issue with the change of TCPIP port from 9119 to 443 as if bind https://passwordstate to the site in IIS then this works but the URL including the domain name does not connect to the Passwordstate back end.

Have tried removing other bindings form IIS site. Have not tried removing other Authorize Server Bindings in Passwordstate as, if does not  fix it, would not be able to get back in to change it back.

Please can someone suggest how to make this work/ point out what we have missed.


Thanks in advance.



Link to comment
Share on other sites

Hi Simon,


Generally all that's require is:

  • Change the Port binding from 9119 to 443
  • Change the Host Name binding to match the DNS entry you've created
  • Select the new certificate for the HTTPS binding
  • And make sure there is no firewall blocking 443

It sounds like you've done everything correctly, but can you please double check the items above. If they look correct, please contact us via our support page, as we might need to see some screenshots to figure out what's going on.



Click Studios

Link to comment
Share on other sites

I had forgotten to say that had already had to add firewall exception for port 443 to get this far so had already triple checked everything mentioned above.


Based on your assertion that it should just work I did some experiments and made it work by using a new DNS name.

We were using the same DNS name as the server name and this seemed to be the cause of the issue when trying to use FQDN to access the application from a browser.


FIX = Create a DNS CNAME for the server, added this to IIS website binding on https port 443 with our domain wild card cert. Did not need to add this new name to authorised servers and can access on this new DNS name.

Just need to update System Settings - miscellaneous - base URL so any links get the new DNS name.


I hope this is of help to someone.





Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...