Jump to content

Auto Launch for Client Based Launcher doesnt work


Recommended Posts



we are running into a Problem when using the Auto Launch for the Client based Remote Session launcher. We have plenty of Hosts where the Auto Launch functions without any problems. The Problems occurs for specific Hosts and everyone else works fine. 


When clicking the Auto Launch Button the Following Appears (Sorry for German Language, its just an RDP window that says that the Login was not successful)

The funny thing is when i click "Manual Launch" and choose the Credentials that are linked to this host, the Connection gets established succesfully. So this means that the Login Credentials are correct.



Same for the Browser based Launcher, when i try the Auto Launch everything works fine. 

The Problem only occurs when using the Auto Launch for the Client based Launcher. 



I dont know where to start looking for a possible cause of this issue, maybe someone got any ideas. 


Thanks for your help


Link to comment
Share on other sites

Hi Findus

Can you check if you have configured any parameters for the specific server?

In an older version of the client based launcher there was a bug with the parameters which led to this issue.

This bug has been resolved in the newest version.

Can you try to remove the launcher, remove the folder if still exists and reinstall the launcher?

Best regards,


Link to comment
Share on other sites

Hi Findushai,


Also, if what Fabian suggests doesn't work, can you try opening Remote Desktop app on your computer, and deselecting the following option?




This is a per machine based option and could explain why this is only happening for some machines, and not others.


Hope this helps:)





Link to comment
Share on other sites



i tried both of your suggestions but sadly none of them worked. 


After that i went to the Event log of the server and saw the Following Event: 

I changed the Servername for security reasons. 


The event says that the username or the Password are bad, but as i already said, all of the other Launchers work fine with the Same Login Credeantials so i really dont know where to look for the Problem anymore. 



Log Name: Security
Source: Microsoft-Windows-Security-Auditing
Date: 26.06.2018 18:25:11
Event ID: 4625
Task Category: Logon
Level: Information
Keywords: Audit Failure
User: N/A
Computer: server.company.net
An account failed to log on.

Security ID: NULL SID
Account Name: -
Account Domain: -
Logon ID: 0x0

Logon Type: 3

Account For Which Logon Failed:
Security ID: NULL SID
Account Name: Administrator@company.net
Account Domain: server.company.net

Failure Information:
Failure Reason: Unknown user name or bad password.
Status: 0xC000006D
Sub Status: 0xC0000064

Process Information:
Caller Process ID: 0x0
Caller Process Name: -

Network Information:
Workstation Name: Company_928_LAP
Source Network Address: -
Source Port: -

Detailed Authentication Information:
Logon Process: NtLmSsp 
Authentication Package: NTLM
Transited Services: -
Package Name (NTLM only): -
Key Length: 0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.
- Transited services indicate which intermediate services have participated in this logon request.
- Package name indicates which sub-protocol was used among the NTLM protocols.
- Key length indicates the length of the generated session key. This will be 0 if no session key was requested.



Thanks for your help. 

Link to comment
Share on other sites

Hi Findushai,


Could you enable logging in your Client Based Remote Session Launcher, and then send me the connection logs to support@clickstudios.com.au?


To enable the logging, edit the C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1 file on your workstation, and change the following parameter to True and then save this change:




There should be a new file in the same folder after replicating the error called pslauncher.log, and hopefully there will be something in that file which might help.


Are you using a local account or a domain account to connect into these machines?  What format are you entering your credentials when using the Manual Launch?  is it domain\username?  or just username?


You're welcome to send this all through to us to our support email address if you like, considering it might have some sensitive info.





Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...