Jump to content

Unecessary Linked Credentials for Remote Session Launcher


Recommended Posts



when documenting Passwords for Postgres Databases, the Documented Entries appear in the "SSH Linked Credentials" Dropdown menu for the Remote Session Launcher. 

The Account Type in for the Entries is PostgreSQL. It´s rather annoying when you only have one actual SSH Credential for a server but have to select it every time you want to use the Auto Launch. This will get even worse for Servers with way more  Databases on them. 


Is it somehow possible to have a Heartbeat for this Database Entries but don´t let them appear in the Dropdown? 










Link to comment
Share on other sites



Can you please tell us if this host has the SQL Server option selected on it, and are all these accounts actually valid SQL Accounts for SQL Server on this Host. If they are not SQL Accounts, what type of Account Types are they that are selected on each of the Password records? You can contact us via our support page as well, if you don't want share any sensitive information here on the forum.


Are you also aware of the Remote Session Credentials feature when you click on Hosts Home? If configured here, you can automatically be logging in with the selected account, and you shouldn't need to worry about what's in this dropdown list.

Thanks very much.


Click Studios

Link to comment
Share on other sites



they are PostgreSQL Accounts and are defined as PostgreSQL Account in the Password Entries. 

We don't need a working Remote Session launcher for PostgreSQL but we want to use the Heartbeat script (which is already working, so yes they are valid) but without all the Entries Appearing in the Dropdown.


Yes we are aware of that Feature but we prefer using the Hosts Tab for starting all Remote Sessions because it's easier and faster and the search usually returns fewer results while being in the Host tab because you don't get results from Lists like Websites or else which arent for Remote Sessions anyway. 


EDIT: I just played around with some settings and noticed that if I change the Host-Type from Linux to Windows none of these Credentials appear in the Dropdown List. Which means that you already Filter linked Credential on an "Account-Type" but only for Windows Host it seems. So why not do the same for Linux and everything else? I think its clear that it doesn´t make sense to put PostgreSQL Credentials into a Menu that's named SSH linked Credentials. 





Link to comment
Share on other sites

Hi findusHai,


After setting up our systems like yours, we agree that the postgreSQL accounts shouldn't be showing as a available account to do a remote session with.  We'll work out the best way to folter these out and will have a fix in the next build.  I'll report back here when this is released:)


Thanks for your patience and we'll speak soon!




Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...