Jump to content

Upgrade from 8.5 8519 to 8556 fails


Recommended Posts



We have an installation of PasswordState 8.5 build 8519 running on a Windows Server 2016 Datacenter VM. I am trying to perform an upgrade to the latest build, 8556.


When performing "Step 1 - Upgrade the Web Files", it hangs very quickly after an error:



- Stopping Passwordstate Windows Service.....
- Upgrade error detected - Object reference not set to an instance of an object. - Method = StopWindowsServiceButton_Click


I have tried restarting the Passwordstate service & attempting the upgrade again, but received the same error. I couldn't spot anything out of the ordinary in Event Viewer.


Do you have any suggestions before I go down the manual upgrade path?


Thank you,

Mike Oldfield


Link to comment
Share on other sites

Hi Mike,


Sorry you're having some issues, and can you tell us if you've followed the instructions for configuring the Backup account in Passwordstate for the InPlace Upgrade feature?


If not, or you're not sure, you can find this information in the Security Administrator's manual under the Help menu - in the Backups and Upgrades section.


Click Studios

Link to comment
Share on other sites

Perfect, thank you!


I'd inherited the system pre-configured by our development team, so I wasn't aware of that setting. This is a dev box I'm testing on, but found the backup account was configured with production credentials which are not present on the dev box. After changing these to the correct dev credentials, the upgrade is now running properly


Thanks again for your help

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...