Jump to content

Error when configuring password reset


brett8187
 Share

Recommended Posts

We configured a lot of our windows servers using the local administrator password reset feature which worked great. We have an identical error on 2 servers

 

Initial reset job error:

Failure: Failed to query Local Administrator Accounts on Host 'XXXXXXXXX' as it appears the Host is not online, or PowerShell Remoting is not enabled.

 

error by testing the script manually myself via the powershell option

Executing for Host 'XXXXXXX' at 4/29/2019 1:42:39 PM.
Failed to reset the password for the Scheduled Task 'Reset local admin manually' on Host 'XXXXXXX' as the Scheduled Task no longer appears to exist.

 

All of our WinRM settings are configured via GPO so they are all identical. I also tested ps remoting from the actual passwordstate server hosting the instance and it was able to remotely open and connect to a session on the server having issues.

Link to comment
Share on other sites

Hi Brett,

 

I can't be sure but looking at the two different error messages makes me think you were trying to run different script here.  The first one looks like you are running a local Windows Account Discovery job, and the second one looks like you are manually running a "Reset Windows Scheduled Task Password" script.  I can tell this by the different error messages that are being returned.

 

Ie the text "Failed to query Local Administrator Accounts" should only be present int he Local Admin discovery script, and "Failed to reset password for the Scheduled Task" text should only be available in the Scheduled Tasks reset script.

 

It's possible the in the first error, that the machine just wasn't powered on when it tried to do the discovery.  For the second one, it sounds like the scheduled task you are trying to perform the reset for, does not exist on the machine it ran against.  Can you double check all this and let me know if you find anything?  I might just be misunderstanding your environment at this stage...

 

I did notice that the name of your scheduled task is called "Reset Local Admin Manually".  Without knowing your requirements and set up, you could possibly use our built in Reset Local Administrator options to do this, instead of putting it into a Scheduled Task?  Here is a forum post which describes how to set this up:  

 

 

 

Does this help at all?

 

Regards,

Support

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...