Jump to content

SSMS not launching


Derek
 Share

Recommended Posts

I have a new installation of PWS.

I am unable to make the SSMS client launch and work through the Client Based Launcher.

I have version 18.1 installed on my computer.

 

I've ran the client based launcher installer.

I've configured my browser (chrome).

When I click the Auto or Manual buttons, it doesn't launch.

 

I've searched the Chrome Preferences file and verified that the psrsl setting is false.

 

 

Link to comment
Share on other sites

Hi Derek,

 

The thing that might be stopping this is the built in pop up blocker in Chrome.  Can you allow popups for your Passwordstate URL and let us know if this fixes the issue?

 

If that doesn't work, can you open the C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1 file, and enable logging by changing then logging variable to $true, and then try to launch a new remote session?  This will create a new log file in your temp directory, which by default is C:\Users\<your_username>\AppData\Local\Temp\PSLauncher.log.  Can you then try launching a remote session, which will write some details to the log file, and then send me a copy of this file to our support address? (Or share it here)  Here’s a screenshot of this setting:
 

SNAGHTML29869707.png

 

Regards,

Support

Link to comment
Share on other sites

I've enabled the logging.

I've made sure pop-ups are allowed and I do see the small window appear.

 

The log file indicates it was successful.

 

Can you confirm that you support the SSMS version 18 and 18.1?

 

Here's the log:  (Sanitized)

2019-06-20 02:27:10 Remote Session Launcher API Key not found for user.
2019-06-20 03:22:53 Remote Session Launcher API Key not found for user.
2019-06-21 08:42:10 Remote Session Launcher API Key not found for user.
2019-06-26 09:56:59 Remote Session Launcher API Key not found for user.
2019-06-27 02:09:21 Opened SQL Server Session to host dev-server.company.com using login credentials adminaccount.

 

Link to comment
Share on other sites

Hi Derek,

 

Open further investigation, it looks like Microsoft have dropped support for passing the password parameter to ssms.exe - see below. Using AD accounts will work fine, but if you want to use SQL Accounts, you will need to use Management Studio 2017.

 

ssms18.png

 

Regards

Click Studios

Link to comment
Share on other sites

I have an AD Account linked under the Hosts tab.

I'm still getting the same results when clicking on the Auto-Launch SSMS button.

 

I'm also getting the same results when clicking the Manual one too.

The small window opens and asks what reds to use, then disappears after I select a credential and SSMS does not open.

 

SSMS does not open or launch.

 

Link to comment
Share on other sites

We've also got a troubleshooting guide in our User Manual, if you are also having issues with RDP and/or SSH.

 

You can access this from the Help menu in Passwordstate, and then navigate to Hosts -> Hosts Navigation Tree -> Troubleshooting Client Based Launcher.

Regards
Click Studios

Link to comment
Share on other sites

Hi Derek,

 

Thanks for confirming RDP works. If you open a DOS prompt and type ssms.exe, does Management Studio launch for you? If not, you might need to hard code the path in the file C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1 - it's at the top of the file.

If it does launch, then possibly there are other issues with Management Studio 2018 that we'll need to look into. As a work around, is it possible to install Management Studio 2017 and try that?

Regards

Click Studios

Link to comment
Share on other sites

ok, adding the path to the PATH environment variable is the key.

 

The default path for SSMS 18 is:

C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\

 

It does launch now, but with the error about the -P parameter not working.

Like you mentioned above it's not supported anymore.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...