Jump to content

Browser Extension - not recognizing website?


Mike
 Share

Recommended Posts

Hi,


We have a few vendor websites that work and auto-fill correctly with the browser extension.  However, after logging in, the extension will re-prompt to save it as a new website right after.   This wouldn't be a big deal if we could use the workaround to ignore it, but I found that:

*If I did ignore it, it wouldn't login at the startup page anymore.

*After logging in manually, it would continue to prompt to save the website.  

 

I found out eventually that I had some 50 odd entries in my "browser extension ignore" setting, because I kept clicking ignore and they were all the same URL.  (Btw, it'd be nice if I could multi-delete from that screen).  Any thoughts or workarounds?  The URL domain is the same before and after (https://somecompany.com/login/ui) and (https://somecompany.com/home)

 

PS. I've reproduced in both Beta and current version of the extension.

 

Link to comment
Share on other sites

Hi Mike,

 

Our browser extensions should only be saving the Base URL for web sites, and not generally anything after https://somecompany.com - as an example. Can you let us know if it is our browser extensions doing this, or maybe someone added the record manually into Passwordstate?

Are there are sites we can test ourselves for this issue?

Thanks

Click Studios

Link to comment
Share on other sites

The site in question is powerdms.com and we currently have a subscription.  I'd be happy to reproduce.

 

I modified my url setting to be the root of the domain, and a single ignore entry prevents the message from reappearing, but it also will no longer autofill now.  

 

EDIT:  Weird - I was trying to reproduce, and now through a series of adding the site, relogging in, logging out, and deleting the site - I can't get the prompt to pop up again.   I'll let you know if this comes back.

 

 

Link to comment
Share on other sites

Just an update - I've been testing more sites and can see this occur with regular frequency.

 

In the URL field for a site, we've pull the full login urls into the URL field.  This enables someone to click the globe icon to login immediately.  Most of these sites have some sort of domain.com/login.aspx or domain.com/login path.

 

Passwordstate seems to prompt "Would you like to save" if the next page redirects to a subdomain (success.domain.com), or adds a path to the URL (domain.com/

I've found that I can add "domain.com" to the ignore list, and that seems to not prompt, and then I can manually select it to fill, but that's not our preferred option either.

 

I know ya'll are working hard.  I'm more than happy to provide more feedback data if needed to help make improvements!  

 

Link to comment
Share on other sites

Thanks Mike,

 

Appreciate the effort and yes we'd like to make our browser extensions work better.  I don't think they can ever be good enough to be honest:)

 

I know you have provided a website previously, but do you happen to know another one that we can create a free account and use it for testing ourselves?  To fix these issues, we need to be able to reproduce it ourselves using some tools we have in our own environment.  I'm not sure if/how we can fix this yet, but if we can reproduce it ourselves it certainly makes it much easier.

 

Regards,

Support

Link to comment
Share on other sites

Hi Mike,

 

Also, can you please do some testing with just the Base URL being record in the password record i.e. domain.com - we have not designed the extensions to work with other pages appended to the Base URL field. We understand the user's will not be directed to the login page, but unfortunately we have not designed it that way.

Regards

Click Studios

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...