Jump to content

Browser Extension - Issue with latest build


Beau P.
 Share

Recommended Posts

Hello Beau,

I'm so sorry - I misread your original post. We haven't had any other reports of this, so we're not sure of the cause at this stage. Could you try the following to see if it will help:

 

  • Restart IIS, then try logging into Passwordstate again
  • Clear your cache in Chrome, and then try again
  • Go to the Help Menu in Passwordstate, open the Web API Documentation page, and then open the Standard Documentation - does this load okay
  • And can you check if this is working for any other users?


Thanks

Click Studios

Link to comment
Share on other sites

1. Tried this. Did not fix.

2. Tried this. Did not fix.

3. Yes.

4. Not working for all users.

 

There is a message in the Audit log for a failed API call every time the extension tries to authenticate:

Failed API Call: An exception has occurred executing an API Script. Error = Object reference not set to an instance of an object. from IP Address xx.xxx.xx.xxx, using a URL of https://<oursite>/api/browserextension/authenticate/.

Link to comment
Share on other sites

@support

I found and fixed the issue. This is our first upgrade after installing the product. Shortly after installing, we copied the install from c:\inetpub\PasswordState to g:\PasswordState and modified the directory for the passwordstate site in IIS to be the new directory. I did not realize that there were 4 applications inside that website so they were still pointed to the old path (which didn't get upgraded). I modified those and restarted the website, recycled the app pools and restarted the service and the extension is now working.

 

Thanks for looking into this with me.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...