Jump to content

browser extension filling fields it shouldn't be


Mark Bell
 Share

Recommended Posts

I have a password entry in for quite a few Fortinet firewalls.  When I go to the Network Interfaces page, the browser plugin fills the IP/Network Mask field with the username of the firewall.  The name of the field is "ip" so I'm not sure why that would be related to the username.  So far, it's happening on every firewall I've tested and the only way to stop it is to uncheck the "Auto-Fill" box in Preferences.  I don't want to do that because I do want the username and password when I log in to the firewalls.

ip-netmask.jpg

Link to comment
Share on other sites

Hi Mark,

 

Thanks for reporting this, and we also see the same thing on Fortinet firewalls - so we will have to review this form filling functionality, and figure out why it's filling these fields. We'll let you know as soon as we've been able to figure out a solution.

Regards

Click Studios

Link to comment
Share on other sites

Hi Mark,

 

We've found the cause of this, and it's due to us trying to update the Fields ID's on the 'Browser Form Fields' tab automatically, if we detect that they are changing. So we are going to have to remove this feature, and customers will just need to manually update these ID fields if they ever change for the logins screens.

 

So this means that for your Fortigate firewalls accounts, they will be incorrect after you are navigating around the internal pages. So after we do the next release, we will probably have to update them manually in Passwordstate.

I hope this all makes sense.

Regards

Click Studios

Link to comment
Share on other sites

  • 2 weeks later...

Hi Mark,

 

Today we have released a new build of the Chrome browser extension (8812) which fixes a few more issues, which includes better form filling for your sites.  The extension should automatically update in your browser, and this doesn’t require you to upgrade Passwordstate at the same time, although we did release a new build of that today as well.

 

If you notice the new browser extension does not automatically fill in the credentials for you, this could be caused a few reasons:

 

  1. You have the URL saved as an ignored URL under either the global admin area, or your own personal preferences.  Screenshots of these areas below
  2. The field IDs have changed on the website, compared to what you have saved in Passwordstate.  Under these circumstances, if you manually select a credential from the icon overlay, this will fill the forms but it will also update the field IDs in Passwordstate, for all records that have the same URL that you have access to
  3. Some websites are built differently, and this can be for many reasons. In this case you can lodge the URL to us here at Click Studios, and we’ll do our best to fix it in a future build.  You can log the faulty URL directly from your Browser Extension now – Please see the third screenshot below

2019-10-21_9-36-40.png

 

2019-10-21_9-36-57.png

 

2019-10-21_9-34-50.png

 

 

 

Kind Regards,

Support

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...