Jump to content

Browser extension issue with Ubiquiti Unifi Controller software


MikeC
 Share

Recommended Posts

Hi,


We're seeing some odd behavior with the browser plugin filling in unexpected fields in Ubiquiti's UniFi Controller software. 

 

I have the latest browser extension installed in Chrome, and the Auto-fill setting in the extension set to disabled. On the UniFi login page the Passwordstate extension icon shows a matching login, and I'm able to click it and login successfully. If I look at the record in Passwordstate at that point and go to the "browser form fields" tab, it shows 'username' and 'password' for the field names (which matches what's in the form.) So far so good.

 

However when I browse to Settings -> Wireless Networks in UniFi, and edit an existing wireless network, the original SSID pops up for a moment, then it's replaced by the username from the record in Passwordstate. This is happening even though Auto-fill is disabled. Also, if I open the record in Passwordstate at this point, the browser form field names have changed to 'wirelessNetworkName' and 'wirelessNetworkWepKey'. If I look at the password change history, nothing shows up even though the browser form fields are now different when I view the record.

 

This has caused some problems - if someone goes in to change a setting, other fields get overwritten that they weren't expecting. 

 

Any thoughts what might be going on?

 

Thanks!

 

 

Link to comment
Share on other sites

Hi Mike,

 

I'm going to have to try to replicate this, and then pass it on to our developers of the extension to see if they can fix it.  I'm fairly certain we have one of these devices I can test on. 

 

What format do you have the URl stored as?  is it a base URL like https://name.com or do you have something appended to the end of the url like https://name.com/login.aspx ?

 

Regards,

Support

Link to comment
Share on other sites

On 1/3/2020 at 5:56 PM, support said:

What format do you have the URl stored as?  is it a base URL like https://name.com or do you have something appended to the end of the url like https://name.com/login.aspx ?

 

The URL was in the password record as https://unifi.example.com:8443. I tried changing it to the full URL for the login screen (https://unifi.example.com:8443/manage/account/login?redirect=%2Fmanage) but it then no longer filled in the account information.

Link to comment
Share on other sites

Hi Mike,

 

I was able to replicate this.  I will need to submit this to our browser extension developers to take a look at, as I don't believe it should be updating the field IDs in this manner.

 

I'll get back to you as soon as I have more information on this.

 

Regards,

Support.

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...