Jump to content

Installation stuck after initial system settings


SampoS
 Share

Recommended Posts

Hi,

 

I'm trying to install Passwordstate but I'm stuck on error. The installation itself finished just fine but after entering initial system settings (AD user, emergency password etc.) I'm greeted with the "An Error Has Occured" page. The database and its tables seems to be created just fine and I'm able to get the error(s) from DebugInfo table:

 

It appears the user's session in IIS has been prematurely ended, causing the following error - Conversion from string "" to type 'Integer' is not valid., StackTrace =    at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)     at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(Object Value)     at loggedout.DetermineSAMLLogoutURL(String UserID)     at loggedout.Page_Load(Object sender, EventArgs e)     at System.Web.UI.Control.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

I haven't been able to figure this one out. The server is 2019 with SQL Express 2019.

Link to comment
Share on other sites

Hi SampoS,

 

Those errors that IIS Session has been prematurely ended can be caused by either Reverse Proxies, AV software on the web server, or possibly a Load Balancer in front of your website.  I'd assume the only one of these things that might be applying to you could be AV software, would that be right? 

 

If so, could you please disable AV temporarily, and then reset the installer, and run through the initial config again?  Resetting the Passwordstate Set up process can be found here:  https://www.clickstudios.com.au/community/index.php?/topic/1663-resetting-the-passwordstate-setup-process/

 

 

If that works, I'd consider excluding Passwordstate from your AV software temporarily to prevent future issues.  This isn't a long term fix as the AV vendor needs to address their issue.  More info about this can be found here:  https://www.clickstudios.com.au/community/index.php?/topic/2472-error-console-errors-due-to-anti-virus-software/

 

 

Does this helps at all?

 

Regards,

Support.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...