Jump to content

Remote Session Launcher not starting


Jay Verhagen
 Share

Recommended Posts

Hi there,

 

We have started testing PasswordState within our company but we are sadly enough running into an issue with the Passwordstate Remote Session Launcher.

The issue we are running into is as follows:

When trying to start a Client Based Launcher from the Hosts tab it does not seem to open either SSH or RDP Connections. I do get the notification of I would like to open the link with the PSLauncher but nothing happens afterwords. I've tried enabling debug in PSLauncher.PS1 script and check the logging but no logging shows up. When running the script from PowerShell ISE I receive a few errors of missing statements:

 

PS C:\Program Files (x86)\Passwordstate Remote Session Launcher> C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1
At C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1:94 char:61
+     if($UserName -like '*.\*' -or $AccountType -eq 'Windows')
+                                                             ~
Missing statement block after if ( condition ).
At C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1:110 char:1
+ }
+ ~
Unexpected token '}' in expression or statement.
At C:\Program Files (x86)\Passwordstate Remote Session Launcher\PSLauncher.ps1:277 char:1
+ {
+ ~
Missing closing '}' in statement block or type definition.
    + CategoryInfo          : ParserError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : MissingStatementBlock

 

It appears something might be broken in the script. I've updated PasswordState to the latest version and also tried Chrome, Edge Chromium, FireFox, Internet Explorer and another system. 

 

Could you please advice what might cause this issue and what we could do to fix it?

 

Kind regards,

Jay

Link to comment
Share on other sites

Hi Jay,

 

Could you please try uninstalling the launcher for us, and ensure the folder C:\Program Files (x86)\Passwordstate Remote Session Launcher is manually deleted.

 

The try re-installing the launcher again and let us know if you still have any issues? Also, do you have any AV software on your desktop which might be inteferring with this?

Regards

Click Studios

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...