Jump to content

IIS Application Pools Stopping


Recommended Posts


You've noticed Application Pools being stopped in IIS, and even if you start them, the next day they are stopped again.  






Disabling the Microsoft Monitoring Service fixes the issue, but for a long term solution, you should exclude the w3wp.exe process from your monitoring service:






Link to comment
Share on other sites

  • 3 months later...


Unfortunately this fix won't work for us. Since upgrading to Build 9435 we have severe problems with the shutdown of the "PasswordstateApps" pool after using the API (Reporting, API, Browser Extension, Reset Portal).

Disabling and / or excluding as described above is not helping to fix the issue.

Ticket is already open.

Anybody else have problems with this after upgrading to 9435?


EDIT/UPDATE: It seems we found the issue. Disabling the service is currently not enough (latest Win2019 server). After removing the service completely, everything works fine again.


Best Regards


Link to comment
Share on other sites

  • 2 months later...



We had the same problem with version 9435, we also updated to the latest version of Passwordstate (9512) but the problem persists.

After removing the Microsoft Monitoring Agent the problem was solved.

We use the Microsoft Monitoring Agent for our server monitoring through SCOM and also Azure monitoring depends on this service.

I hope Clickstudios can fix this problem because we currently have no monitoring/alerting on our Passwordstate servers.


Kind Regards,


Link to comment
Share on other sites

  • 8 months later...

**Update on this 27th January 2023**


A customer has reported that they had their server hosted in Azure, so by default this server came with the Microsoft Monitoring Agent (MMA).  He then said that he also had the MMA deployed to his On-Premise network, but this was done via SCOM and he confirmed that the two agents were different builds. 


He then uninstalled the MMA version on Azure server, and reinstalled the On-Prem MMA version, and this solved the issue. (Thanks to Aaron for supplying this info)



Click Studios.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...